3.3.f Implement and troubleshoot VRF lite

3.3.f Implement and troubleshoot VRF lite

VRF allows us to have a separate routing table instance for clients

 

Configure all of the routers, their interfaces, loopbacks, OSPF processes. Identify any gotchyas.

R1:
int g0/0
ip add 192.168.1.2 255.255.255.0
no shut
ip ospf 1 area 0

R2:
int g0/1
ip add 192.168.1.2 255.255.255.0
no shut
ip ospf 1 area 0

R3:
en
conf t

vrf definition client1
exit

vrf definition client2
exit

int g0/0
vrf forwarding client1
ip add 192.168.1.1 255.255.255.0
no shut
exit

int lo1
vrf forwarding client1
ip add 8.8.8.8 255.255.255.255
no shut
exit

router ospf 1 vrf client1
router-id 1.1.1.1
network 0.0.0.0 255.255.255.255 area 0
exit

int g0/1
vrf forwarding client2
ip add 192.168.1.1 255.255.255.0
no shut
exit

int lo2
vrf forwarding client2
ip add 8.8.8.8 255.255.255.255
no shut
exit

router ospf 2 vrf client2
router-id 2.2.2.2
network 0.0.0.0 255.255.255.255 area 0
exit

The router ID is required or else OSPF will not choose a router-id when using VRFs

https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst4500/12-2/31sg/configuration/guide/conf/vrf.pdf